Page 68 of 74 FirstFirst ... 18586667686970 ... LastLast
Results 671 to 680 of 735

Thread: EXPIRED..Timed event: A Galloping Gift 12-24 Feb

  1. #671
    I sent out the adventure at least 6 times and never got headdress, what a waste of time. This game is getting deleted as it's just too disappointing to play for nothing. I'll stick with castle story.

  2. #672
    So sad. I worked hard and wasted no time. I sent out as many adventures as time would allow (6?; 7?) and no headdress. After hitting a gem trap, not enough gems to skip and after all of this there's no way I will spend money to purchase something I feel we have all earned. I believe I will just say goodbye to this game and play where I have fun.

  3. #673
    Executive Chef
    Join Date
    Dec 2013
    Location
    Glimmer Forest
    Posts
    4,447
    Quote Originally Posted by ShibuyaCloth View Post
    Well now heading for trip #6, I suspect the cleaning staff over did their duty.
    I should not have searched the banquet hall, but the cleaning storage room! Seems the headdress was not there after all. Now Cinderella needs to tow her carriage alone ;p
    Last edited by ShibuyaCloth; 02-23-15 at 12:14 PM. Reason: typo
    Castle Story "Tome of Knowledge", visit for: Interactive Map, Inventory Cards, Detailed Inventory, and more...

  4. #674
    So the goal expired and I chose not to use gems to complete anyway. Then it popped up again with a picture of the horse so I paid the 25 gems and didn't get a horse so what was that all about? It said would you like the reward anyway with a picture of the horse and then jumped to expired goal, an unlikely steed. I can't find that one in the list of goals so I don't know where I am at. Has anybody skipped through all these? How much total gems will it cost total?

  5. #675
    Fashion Designer
    Join Date
    Oct 2012
    Posts
    711
    I didn't finish the event but had the option to buy the horse for 25 gems, so I did. I grabbed the horse from storage and placed the horse and the game re-sync'd (not a connection issue) and the horse disappeared. The option to finish/buy the horse was there again, so I did it again. Placed the horse again, saw the timer to collect was 4 hours and the game re-sync'd (not a connection issue). This time there was no option to finish/buy the horse for 25 gems.

    What's going on here?

  6. #676

  7. #677
    Times up?
    Last edited by SunnySunsets; 02-23-15 at 01:42 PM.

  8. #678

    Pffft

    Sucks but I see I'm not the only one who wasted numerous picnic baskets and days on a timed event. This could be a good game but too many glitches and I'm not wasting 25 gems on something that I should have got at least 4 days ago. Delete...delete!

  9. #679
    Farm Supplier
    Join Date
    Nov 2013
    Posts
    67
    I did 7 Trips to the Banquet Hall and still no Plume, so I bought it for 25 Gems, found the Horse in storage, but am unable to place it, have tried to buy it and place it 5 times now, have reset IPad and still can't place the Horse so how are we going to be able to finish the Task? I see by above posts I am not the only one with this problem, what's going on Team Lava, should we just buy it and not place it until this issue is resolved?

  10. #680
    Farm Supplier
    Join Date
    Nov 2013
    Posts
    67
    I just tried to buy the Horse and leave it in storage game will not let me do it

Page 68 of 74 FirstFirst ... 18586667686970 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •