Results 1 to 4 of 4

Thread: Missing monsters

  1. #1
    New Resident
    Join Date
    Feb 2013
    Posts
    1

    Missing monsters

    Anyone else missing some monster action recently?
    I've triple checked all around and I"m sure that there isn't a sneaky troll hiding anywhere but it seems it has been a couple of days since my last monster encounter.
    Normally I wouldn't be complaining about this but I'm still trying to complete the lovecupines pink pelt challenges.
    I've tried a number of times allocating out all my energy at once but with no monster of any type appearing.
    Any suggestions would be most appreciated.

  2. #2
    Nightclub Owner
    Join Date
    Mar 2011
    Location
    Australia
    Posts
    8,805
    I think they've all gone to my kingdom! I've had at least 6 monsters today.

    It's good that you've checked for a hidden monster. I'd suggest force closing and restarting or deleting and reinstalling. This can often fix different issues.

  3. #3
    Rhino Keeper
    Join Date
    Jan 2013
    Posts
    133
    Quote Originally Posted by maguar View Post
    I think they've all gone to my kingdom! I've had at least 6 monsters today.

    It's good that you've checked for a hidden monster. I'd suggest force closing and restarting or deleting and reinstalling. This can often fix different issues.
    Same here! Wow I have exactly the same story as you Maguar. I've battled so many glimmer trolls today lol

  4. #4
    Rhino Keeper
    Join Date
    Nov 2012
    Posts
    102
    It is the opposite for me. I've been battling monsters all morning over here in my neck of the woods! At least 4 lovecupines and 3 trolls and a fang. No skunks tho.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •