Results 1 to 3 of 3

Thread: As Busy as a Baron Pond DISAPPEARED

  1. #1
    Farm Supplier
    Join Date
    Aug 2014

    As Busy as a Baron Pond DISAPPEARED

    ID: linmii / Kingdom name: Linford
    iPad Mini 5
    OS 14.6

    I began the new event "As Busy as a Baron."
    I placed the pond and upgraded it 2 times.
    While looking to see what the requirements were for the next level, I decided to move the pond to a new location.
    Then I tried to rotate the pond and poof, it disappeared!

    I closed the game and reopened it 2 times.
    I looked around to see if it relocated somewhere, it didn't.
    I checked the market to see if I could buy a new pond... it's not available.
    I shut down my device and restarted it, still no pond or the ability to repurchase one.

    Can you please help?
    Thank you.

  2. #2
    Farm Supplier
    Join Date
    Aug 2014
    I tapped around the area where I tried to move the pond and found a hidden ghost of it. When I rotated the ghost my pond reappeared.

    So all is good now!

    Last edited by linmii; 06-24-21 at 03:45 PM.

  3. #3
    Thanks for letting us know you were able to find it!
    Storm8 Staff - [S8] HungryGoblin
    Need help? Contact Storm8 through
    Got a new device? Transfer your games here!
    Have Facebook or Twitter? LIKE and FOLLOW us here!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts