Does anyone know if I can get something back in my kingdom that seems to have disappeared?

I spent all last week amassing 10 gold tokens to trade at the trade wagon for my second Lorelei's sapphire. Then today, I clicked on the wagon to make the sapphire. A couple hours later, it showed the crate with the check mark and I clicked to collect the sapphire. The wagon darkened like usual, and then got lighter like usual when an item is collected. Except in this case, I never saw the sapphire pop out. And then another (now double image) of a crate and check mark appeared, and I tried to click to collect with the same result as the first time.

I tried closing and reopening the game, and now my trade wagon is empty and ready for a new craft, but all 10 of my gold trade tokens are gone and the sapphire I crafted is nowhere. :( My Princess Lorelai's Fountain goal still says 1/2, which is what I had prior to the monster hunt and the crafting I did today.

Please help! Is there anything I can do?? I would hate to lose a week's worth of monster fighting :(