Results 1 to 2 of 2

Thread: Purchase not showing up

  1. #1

    Angry Purchase not showing up

    I made a purchase, or thought I did, for $24.99. Then, I got an error message. I tried closing the game and re-opening it, turning off the phone, and uninstalling and reinstalling the game. Everything else still there, tried the purchase again. Since the purchase option was still available. It kept saying, "This In-App Purchase has already been bought. It will be restored for free." There is a little OK button on the screen, after I try to do the purchase. I WANT MY ITEMS, AND I WANT THEM NOW!

  2. #2
    Senior Moderator kooky panda's Avatar
    Join Date
    Mar 2011
    S8 FORUM
    I am sorry this happened. Please contact support for assistance.
    Please send them a copy of your receipt showing the purchase did go through.

    See support link in my signature.
    Need me? Send Me A Private Message

    Note: Due to some personal matters, I will not be on over the weekend.

    Contact Storm8 by filling out this form: support.storm8.
    How to submit Support Request

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts