View Full Version : Solved Cant play my level again in my new tablet!

07-19-16, 07:59 AM
Dear sirs, ive got a new tablet, i installed fronzen mania, but the game started in the first level 😟 i was in the level 182 or 183, maybe higher, im not sure but it was more than 180 im sure. I made the 15 conquests and it keeps saying that, but cant play my level again...i log in my facebook and google play accounts, but the problem continues, im desperate 😟what can i do in my tablet to get again my level??? Please help me!!!!!

07-20-16, 05:31 PM
Anybody can help me please??? Im very disappointed with this game...if i know people who want to play this game ill tell them better not :(

kooky panda
07-21-16, 10:30 AM

You can try logging into your games by following the steps shown on post 1 of the above thread.

If you have issues, please send an email to support@storm8.com for assistance in recovering your game.

07-21-16, 07:29 PM
Thanks for the answer. I installed again the game where i used to play it, i mean in my other tablet, and its fine there, i was able to play in my level ☺ but that tablet is no more mine, i gave it to my sis, i wanted to play the game in my new tablet but its completely impossible...im gonna read that info to see if i can resolve my problem but i think ive already read it, i think ive tried everything ��

07-28-16, 06:08 PM
Thanks sooo much to the storm8 team!!!! My problem is resolved! Thanks for helping meeeeee!!!!! :D

kooky panda
07-29-16, 12:37 PM
Oh wonderful! Thanks for letting us know everything worked out!!!