View Full Version : Stuck at Carriage Conundrum even with Wedding Carriage ready

05-19-16, 08:23 PM
My id: evalovely15
Device : iPhone 6
OS: iOS 9.3.1
I collected all the Wedding supplies required for the wedding carriage, but the quest Carriage Conundrum to collect supplies did not go. I even upgraded the carriage to level 1 but still my quest is stuck at collect supplies.
I tried force closing the game and starting again, but still no luck. Please help.

05-19-16, 09:46 PM
Build: 5 Lace, 2 Wedding bells, 20 Rose petals, 5 Ribbons - all come from the new Royal Exchange trade

Can you please look through the first post which has the goal information and notes etc, and check that you have the right number of items. There are screen shots of everything. If you do, please send an email to Support so that an agent can check your game. S8 Support email: support@storm8.com

05-20-16, 05:19 AM
Thanks for your reply SpiritWind00. I did have all the items and infact even built the wedding carriage, but it was still stuck at the quest to collect supplies. It took one more royal exchange trade for the supplies to register, and now I have been able to progress.

05-20-16, 09:16 PM
Ok, that's good news... Thanks for letting us know.:)