View Full Version : Weird Timer Glitch, Unusable Farms?

11-01-15, 08:09 PM
Hi, some help would really be appreciated!

So I just opened my game (on iPad, 4th generation) and checked on my Banshee dragon which was done evolving to Level 7. Completed the third act of Chapter 6 to receive some Mystic Maps. Then bizarrely, Chapter 7 immediately started, even though it was too early. Then my game kind of freaked out, and several timers became messed up!

My Banshee dragon is back into the Evolution Temple, and has 25 minutes left. Weirdly, my Large Farms are now being rebuilt! They have about 22 minutes left to be built, even though I built them days ago! Finally, my small farms are also "being built", in that they have fences around them and cannot be used. However there is no timer, and I cannot store or sell them in any way, meaning I have three unusable farms now. :(

My food or coins have not changed. I am mostly concerned about fixing my small farms, as they have no timer and will be under construction forever now :(

Oh and by the way, yes I have tried closing and reopening the app. Everything stays as it is as I have described.

11-01-15, 08:40 PM
Okay, never mind... When the large farms built themselves, the small ones also became built. Lost the food I was growing, but overall no major damages. Thankfully this is resolved now!

kooky panda
11-01-15, 08:42 PM
Oh I am glad this worked out! :)