View Full Version : Bugs won't let me finish the last round even with a ultimate

07-12-15, 09:04 AM
Fire Giant Dragon Tournament
Come on TL sort this out , I cannot finish this last round even with an ultimate on the last round , 5 times on the last move the game has crashed and shut down , once using Sharman I would have won on the last fragment.

I have tried to ultimate and same thing happens on that last move the game crashes, I lost the first 24 hours because of the incorrect set of dragons, not helped by being in UK with a different time zone.

I get to the last round and even cant finish with ultimate once because the game crashes as soon as the ultimate button is touched.
Tried with spirit warrior epic as well but same things happen x 3
I have switched off and back on twice but no difference to result it still crashes as least give me this darn dragon please, I want it over and finished I'm not happy .......

Storm id Pern Magic
IOS 8.4
Can't take photos as game crashes

07-12-15, 12:32 PM
Glad I'm not the only one!

07-12-15, 12:39 PM
Me too... I'm not able to finish the last round because the game always crashes :mad:

07-12-15, 01:04 PM
Me too... I'm not able to finish the last round because the game always crashes :mad:

Uh uh... It's incredible... I'm on the last round and the game always crashes because... my Fire Giant is already in my storage! :)

07-12-15, 03:13 PM
Same for me : i can not finish last round even with ultimate : it crash just before.
I think this affect all those with 19 rounds instead 18 .
May be it is because fire Giant is already in storage as you said LOL

07-12-15, 03:27 PM
Son of a .........whaddya know, haven't finished the tourney but it is in my storage. Screenshot time!

07-12-15, 08:46 PM
I have lost 68 gold on this. Each time it crashes it resets the arena & I have to pay 4 gold to open it (twice! 8 gold). I've pressed the ultimate button 2x which is 30 gold apiece! I don't want this to be confusing, I have been tossed out of the game twice. The first time I honestly couldn't believe it was happening so I tried again. Let me add that in each time after pressing ultimate it did not finish the round. I was left with a sliver of red & my opponent could get another shot at me but the game crashed & I was back at my home screen. So not only do I not have the winner dragon, I don't have 68 gold!

Oh, I could have won with my moonlight dragon. THREE times I was one hit away on the 2 screen with a red sliver left & the game crashed! I should have know something was going on.

I would like the Fire Giant Dragon and a return of my 68 gold please.

07-12-15, 10:13 PM
Same here, and after reading here, i checked: I also have it in storage allready.... Pfff lost several hours of sleep over this, because of different timezones and the deadline :(

07-12-15, 11:58 PM
I had an extra round added onto my battle arena, fine. Irritating but doable. Now I've spent over 50 gold trying to defeat this impossible round. Just when I was about to defeat it (I'd spent 20 gems to get there, and fine I'll accept spending those), the game kicked me out. I reload the game and it doesn't crash when I lose the next four times. Fine. Time is running out so I'll just speed up again and use ultimate. Except the game keeps crashing! Wtf.

[S8] Elsa
07-13-15, 10:41 AM
@Pernmagic - You've completed the Tournament and your Dragon is in storage.

07-13-15, 10:51 AM
Elsa;1142107']@Pernmagic - You've completed the Tournament and your Dragon is in storage.

Thanks, I found out last night from the forum what the result of the initial glitch caused at the end , I have the dragon but it would have have been great to complete without the hassle caused by the initial glitch :)