PDA

View Full Version : Daily Bonus not working



mamamitchell81
03-12-15, 07:08 AM
The Daily Bonus I get is not always being added to my total. Sometimes it's added, sometimes it's not.

tclark13
03-18-15, 11:58 AM
That's exactly what I was coming on here to post about. I have hit the collect button twice today ($300 per bonus so I should have $600) and it only actually gave me the coins once ($300 total). Yesterday I hit it three times throughout my work day (should be $900) and it only gave me the coins once ($300 total). Extremely irritating.

friscosharkboy
03-20-15, 10:39 AM
I have noticed this problem for several weeks. First logon of the day, I get my treasure chest reward. Then I quit the game and log back in. Then my $300 daily bonus sticks.

DoeZ0763
05-27-15, 08:52 PM
Hey peeps...glad to see that I'm not going insane and that it's not just my game alone. I actually started noticing this awhile back when I'd open a chest and then go to collect my daily $300 bonus...I was basically at that point just collecting cuz I had almost wiped myself out or at least gone below my preferred level of what I like to have in my "bank"...so as I was going on with my collecting (I had a good memory of what was in my bank at all times) this one morning before I went to open a chest and it all covered my totals something didn't look right...I opened a chest and it was added to the total only it was less than what was in there from before...now I'm like wtf so I collected my $300 bonus and tallied up that total and went on with my other games...came back a few hrs later to collect again and the same thing happened all over again. The total I had from before wasn't the total that was being shown...so I went about collecting and got a new total only this time after it was done I took a snapshot. And then a few hrs later when I collected again it happened again and this time I saw the actual proof with my snapshot. Has anyone handed in a ticket to report this problem at all? Just curious cuz obvious there's others with the same problem as well.